Author Topic: Engine cutting out under heavy breaking or at a stop  (Read 190 times)

Offline EphChi

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 7
  • Karma: +0/-0
  • Novice Rotary Owner
    • Isle of Man
    • View Profile
Engine cutting out under heavy breaking or at a stop
« on: May 13, 2020, 02:02:19 PM »
Hey guys, im looking for some advice regarding my FD 13B cutting out when i come to a stop both breaking gently or under heavy breaking. I has recently had an engine rebuild by Rotary Revs and when driving the car back it ran all fine. I then got on the boat from Liverpool to IOM and when driving the car home it started cutting out when coming to a stop, i could see the Voltage decreasing slightly more each time i broke or when the lights were no or even radio. Would this sound like an alternator issue or battery? when the rebuild was being done the original loom that was in the car was hacked up by the previous owner(s) and needed to be replaced by a second hand one when placed back into the car, could this have also been the problem?

Also on a side note when the car was initially started it leaked out alot of coolant but we couldnt find the location of the leak and when i was driving home i stopped at a service station and there wasnt any leaks or puddles under the car does anyone have any idea what could the issue as the radiator and pipes were replaced about a year before the rebuild.

any help or advice would be greatly appreciated!

Matt

Offline boosted

  • MRC Full Club Member
  • Major Contributor
  • *****
  • Location: Westbury Wiltshire
  • Posts: 10,036
  • Karma: +25/-1
  • Worryless, Dream more.
    • View Profile
Re: Engine cutting out under heavy breaking or at a stop
« Reply #1 on: May 13, 2020, 06:41:03 PM »
It could be several things.
But i doubt battery or alternator  as you would not be able to restart and run out of juice on way home.
Is this car running an apexi ecu.
You can look at the sensor menu..particularly the clutch and nuetral switch as these bring the revs up when coming to a stop.
Or an incorrect setup of tps whether they adjusted or not at rebuild ? Again you can see these values on the display.



Sent from my SM-N950F using Tapatalk

92 FD rx7 Twins 13.5psi.  EX Track car
EAT SLEEP ROTOR REPEAT.

Offline clive

  • MRC Founder
  • Administrator
  • Major Contributor
  • *****
  • Location: Kent
  • Posts: 11,300
  • Karma: +30/-0
    • View Profile
    • http://mazdarotaryparts.com
Re: Engine cutting out under heavy breaking or at a stop
« Reply #2 on: May 13, 2020, 08:26:41 PM »
Sorry to hear you are having issues.
For the cutting out as Jon indicated, check the Throttle Sensor settings (see section F77 on the link below)
 
https://drive.google.com/drive/folders/0Bzy-cXUDftdrMDc5M2E0MDEtNmYwNy00ZjJiLTkzZTEtMTI1YjMwMTM4ZGIw?hl=en_US

I am more conserned about the coolant.

When topping up from cold only check the cap actually on the engine and if you can see water its OK. If all three tanks are filled it will blow out water. Just use the engine one and the system sorts itself out.

Hopefully there was just too much water in the system, however if the engine is still pushing out water and you can hear gurgaling or thumping sounds, do not drive the car and call Rotay revs !

All the best Clive