Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - JamesP

Pages: [1] 2 3
1
3rd generation RX-7's / Re: James' 92 RZ build
« on: October 20, 2019, 07:42:46 PM »
Wow, this is a bittersweet moment for me. I've been keeping half an eye out for this thread and then during a boring night shift spent wandering the web, BOOM here it is! Made me realise how much I miss the old girl!

She's looking well though, and I'm glad she's gone to someone who has the time to look after her needs and give her the TLC she deserves.

I have to say that I'm a little disappointed to see some of the things you.found on her, WGT is the only place that's done any work on the engine, and I paid handsomely for it, so to see the bodge on the rats nest irked me somewhat. I honestly had no idea about it but it does make sense looking back regarding the way she was running toward the end.

I bought myself an NA MX5 shortly after you took her away, doesn't quite give me the same buzz as the old girl did, but it's RWD and has pop up lights!

Well enjoy her mate, and most importantly, look after her! I hope she puts as many smiles on your face as she did mine, and if you decide you want to get rid at any point, you know where I am! I politely request first dibs!  :))

Hi John, how's it going? Hope you got the house sorted as I remember you were renovating it when I came to view the car?

I'm glad you've seen the thread and are happy to see how the cars going. I've put a lot of time into her to keep her to the standard you kept her in.

I was also surprised to see what I found after knowing you only had the car looked after by WGT but I've unfortunately been hearing less and less good things about them.

I certainly will continue to enjoy and look after her. Easily one of the best cars I've owned and absolutely love it. I do remember you requesting first dibs if I do ever sell, although everything is for sale for the right offer ;)

2
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 25, 2019, 09:31:35 PM »
Took the car out tonight. Used the opportunity to get a few photos.









And before anyone asks the tyre marks weren't me. Looks like someone had fun before I got there though.




3
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« on: May 25, 2019, 12:39:21 PM »
You not liking the wheels then?

Sent from my SM-G973F using Tapatalk


4
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 25, 2019, 12:38:14 PM »
Got the trim finished for the defi gauges. Bit more of a Matt finish than I wanted but it will do.



Also got the correct fittings for the water temp sensor. Got that installed and working.





Then Finished off getting it in place above the head unit.




5
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 25, 2019, 12:28:37 PM »


Now  its shiny and looking splendid..well half of it....those crashing thoughts are creeping into my mind...i may not go on track at JDM combe, ill decide on day or decision will be made for me if it fails mot on summit....i need to dial it in been quite a few changes and will be fresh alignment and a packed show is not the place to push a bad set up.
If its raining no way atall...ha ha.

Sent from my SM-N950F using Tapatalk

Yeah first drive out at a busy show probably isn't the best idea. Your car is looking very nice now.

Sent from my SM-G973F using Tapatalk


6
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« on: May 25, 2019, 12:25:59 PM »
Wheels looking good against the red

Sent from my SM-G973F using Tapatalk


7
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 25, 2019, 09:29:42 AM »
Your interior is very nice mine is not ha ha gaffer taped in places to stop bits falling out on track...

Sent from my SM-N950F using Tapatalk
Haha nothing wrong with a bit of gaffer tape. I'd be too worried about crashing mine to take it on track

Sent from my SM-G973F using Tapatalk


8
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« on: May 25, 2019, 09:27:04 AM »
New red looks good! I think the wheels will go well with it

Sent from my SM-G973F using Tapatalk


9
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 25, 2019, 09:18:26 AM »
Looks great that. Very oemish.

Sent from my SM-N950F using Tapatalk
Thanks. That's what I was aiming for. I'm finishing it off today so I'll get some pics up of it finished.

Sent from my SM-G973F using Tapatalk


10
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 24, 2019, 08:39:16 PM »
Got a defi din gauge set up to replace the existing gauges and tidy up the interior. I want to get rid of the pillar mount I have at the moment and wanted something that looks almost standard, as personally I'm not a fan of gauges mounted everywhere.



Comes with everything needed to fit it.



Decided to tee the water temp sensor in the throttle body coolant hose. Been reading online where to fit it and it seems a popular way too do it on the American forums. Plus it's tidy and hides the sensor out of the way. Ordered the wrong size fittings though so haven't got that sensor fitted yet. Car already had a oil temp gauge so reused the existing oil pedestal adapter for the new sensors.



Wired it into the CD player loom so it's easy to remove if I ever need to and saved cutting up the cars original wiring loom.





Can't find a plastic trim anywhere to fit the gauges so figured I'd make of out of mdf and spray it black to match the plastics.



Got the mdf in primer just need to pick up some paint tomorrow to finish it off.

11
3rd generation RX-7's / Re: James' 92 RZ build
« on: May 11, 2019, 08:25:51 PM »
So I finally got the car running! After speaking to injector tune who cleaned the injectors it turns out they can stick closed after cleaning. So after putting power to it and tapping the metal body it freed up. Put the car back together and it fired up at last!

https://youtu.be/HgQL4XvqSp8

Everything seems ok so far. The idle is a bit high but I think the IAC valve is sticking. I have improved it since the video but still needs a bit of work to get it perfect.





Cleaned up the intake pipes as well. Still want to clean the whole bay up more but I'm happy with how it is at the moment.


12
3rd generation RX-7's / Re: James' 92 RZ build
« on: April 21, 2019, 05:22:21 PM »
Ok mate cool...can you unstick yourself? Reverse flow..remove 12 v and blow in reverse?

Sent from my SM-N950F using Tapatalk

I was wandering if I could unstick it tbh. Although I didn't want to risk damaging it. Figured it was best to send it back to injector tune as they flow tested it the first time and let them sort it.

13
3rd generation RX-7's / Re: James' 92 RZ build
« on: April 21, 2019, 05:11:16 PM »
Feel your pain...not good atall...are you removing them all for checking...ideally they all need reflow testing.
The stuck 1 if you can get 12v across the pins and it doesnt click and open then yep thats your prob..if it does however could be loom fault and break in continuity...these looms are hard brittle and old now...just think its worth check before away.
Ive energised and blown through injectors in the past to verify ok.


Sent from my SM-N950F using Tapatalk

I wasn't going to remove all of them. They've all just come back from flow testing and supposed to be perfect. I've put 12v across both primaries and secondaries. Only 1 primary doesn't click open.  Loom seemed to be ok. I checked continuity at the plug and it's getting power so hoping wiring is all ok.
I have read that it's not uncommon for injectors to stick after cleaning if they have been unused for a while. Mine have been fitted, unused, while I built the engine back up so hoping it's nothing major and can be cleaned and tested again. Then go straight back in the car.

14
3rd generation RX-7's / Re: James' 92 RZ build
« on: April 21, 2019, 04:49:52 PM »
How frustrating

Hope you can get at them easily. Fingers crossed
It certainly is. I thought it would be running by now. Hopefully this is the last setback I'll have.

Definitely not easy as they're right down underneath everything on these. I've managed to make room and remove the stuck one today. Also  tested the others and they are working.  Hopefully the company that cleaned them will help me get it sorted.

Sent from my SM-G973F using Tapatalk


15
3rd generation RX-7's / Re: James' 92 RZ build
« on: April 21, 2019, 04:04:21 PM »
Been a while since I've updated this. Finally got the engine back in the car. Was fairly easy getting it back in, couple of bits took a while as I couldn't remember how they went back but got there eventually.





Unfortunately the car didn't want to come back too life. Had a few issues. First was the ignition amplifier stopped working. It had been wired to the leading coil so had I spark on the trailing plugs not the leading. Removed that and still had issues. Removed the wiring harness for the coils to find the wiring wasn't the best and the cable inside the leading connector plug had pretty much snapped, hanging on by a couple strands of wire. Sorted that, put the car back together. Hoping that had cured my issues, tried starting it and eventually got some signs of life from the engine. It did start but only ran on the front rotor.
So that brings us to today, I've took everything apart again. Found that the rear rotor primary injector is stuck closed. Bit annoyed as I had the injectors sent of for cleaning and testing so not sure why this has happened. I'll be speaking to the company that cleaned them on Tuesday and hopefully they can get it sorted for me. Fingers crossed the next update will be the car is actually running.

Currently still sat looking sorry for itself in bits again.






Pages: [1] 2 3