Recent posts

Pages: [1] 2 ... 5
1
The first rotary I can remember seeing in the metal that made an impression on me was the MRTE Gp B cars at 1984 RAC scrutineering in Chester and then the following day at Chatsworth.  Clive I also remember the Yellow RX-8 mock up and then seeing the Mazda UK Blue display car that they did tour with around UK in early summer 2003 (I missed a f [...]
2
Rotary and General Chit-Chat / Re: NSU....
« Last post by boosted on December 18, 2018, 07:21:12 PM »
It does look like the paints holding it together...Sent from my SM-N950F using Tapatalk
3
Rotary and General Chit-Chat / Re: NSU....
« Last post by RE5 on December 18, 2018, 10:59:35 AM »
They are very similar to the RX series in that they hide rust very well.................if there is a lot of rust visible, it does not bode well for the underneath.   Inboard discs, stainless bumpers, lightest power steering I have known, independent all round suspension, semi automatic 3 speed box with torque converter (Clutch controlled [...]
4
Rotary and General Chit-Chat / Re: NSU....
« Last post by Jamie R on December 18, 2018, 10:40:58 AM »
It looks a bit tired. I would be scared to take that one on. However, if it was bit less "ripe", it would make an ace street sleeper with a high powered RX7 plant and drive train. Confuse a few boy racers at the lights.
5
Rotary and General Chit-Chat / NSU....
« Last post by boosted on December 18, 2018, 10:18:08 AM »
look what i found in copart....https://www.copart.co.uk/lot/52787268
6
Just realize, I dont remember when I saw rotary for first time. I quess it was -83 local rally girl rallying GR2 FB...First time I saw RX-8 was in car show. It was yellow Lähetetty minun E2303 laitteesta Tapatalkilla
7
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« Last post by re japi on December 18, 2018, 05:56:12 AM »
Bugger... Lähetetty minun E2303 laitteesta Tapatalkilla
8
First rotary I saw was also Ro 80, back in the very early 70's, when I was still at school and trying to earn some cash as a petrol pump attendant at a local Shell forecourt. I can clearly remember that customer and his car as he was very proud of it. The only other car I can remember vividly was the garage owner's car, a Jag, as I was fa [...]
9
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« Last post by Casey on December 17, 2018, 07:39:56 PM »
So sorry to hear that Jon, and just as things were looking up on the health front too 
10
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« Last post by clive on December 17, 2018, 07:26:28 PM »
Arrrrrrrrrrgggggggggggggggg
11
3rd generation RX-7's / Re: BOOSTED FD BUILD.
« Last post by boosted on December 17, 2018, 07:16:23 PM »
spoke to soon....3 hours in A&E today....   got some magic cream....
12
The first Rotary I saw was a Ro 80 screaming down the Autobahn when I lived in W Germany during the 70s, so when I could I got one & restored it & sprayed primrose yellow:-
13
May 2002 Motor Show@the NEC.This was the first official showing of the RX-8 and I immediately found out from Mazda that they couldn't let the public near it because it was not real!!As you will see though, I talked my way into having a sit in, after all it was yellow  .The yellow was actually the RX-7 FD yellow but looked gorgeous in a mi [...]
14
Rotary and General Chit-Chat / Re: TODAYS QUICK PIC
« Last post by clive on December 16, 2018, 10:01:09 AM »
Strangely, something tells me I like that colour     
15
RX-8's / Re: She's Back On the Road not completely done but good enough
« Last post by boosted on December 16, 2018, 05:07:24 AM »
Have a good run out today, few beeps!!!Sent from my SM-N950F using Tapatalk
16
Rotary and General Chit-Chat / Re: TODAYS QUICK PIC
« Last post by exiled-viking on December 15, 2018, 07:24:45 PM »
one for today
17
RX-8's / Re: She's Back On the Road not completely done but good enough
« Last post by clive on December 14, 2018, 08:33:07 AM »
Have fun Sunday
18
RX-8's / Re: MX-5 NC with RX-8 231 Engine
« Last post by Paul_13 on December 13, 2018, 10:43:45 PM »
Still getting p0032. I've checked all wire connections and I'm getting a 0.32 ohm resistance reading on what should be the sensor earth back to the ecu... Something not right there. I'll just zero out the dtc I think.550 miles in now Sent from my SM-G965F using Tapatalk
19
Rotary and General Chit-Chat / Re: Rotus Project Build
« Last post by boosted on December 13, 2018, 09:44:17 PM »
Must be looking at old photo..tried hylomar nope. Original rubber seal dried up and cracked..made 1 out of ptfe 1mm thick white sheet i procured from work.  Made a gasket a ring with the stud holes stamped out. Sent from my SM-N950F using Tapatalk
20
Rotary and General Chit-Chat / Re: Rotus Project Build
« Last post by Jamie R on December 13, 2018, 09:34:21 PM »
The black sealant was PTFE?
Pages: [1] 2 ... 5