Author Topic: RX7 turbo 2 issues  (Read 832 times)

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
RX7 turbo 2 issues
« on: September 03, 2017, 06:23:10 PM »
Good evening Guys,

So im having big issues with my turbo 2, have been for the past year.

basically the chassis loom melted it self into on big solid wire one day last year, since then ive changed the chassis loom, changed the engine loom and changed the battery loom.

so the issue i have is that the car idles perfect, will rev up perfect, gets warm, still revs fine, then you drive it, you do one full boost got to do it again and as soon as you step on the accelerator the engine dies, come off the accelerator and it comes back to life. Turn the car off and on again can do one boost and then it does the same thing again.

so far i have checked all coils, they are fine, new ht leads, new sparks, new fuel pump, changed all vacuum lines, tested alternator is charging correctly.

im at a stand still and dont know what to try next. if i cant fix it, i will be renting a container and dry storing it until i save enough for a 1j and box to drop into it. had a year from hell with this car. any help would be amazing.

Offline Fcboss

  • Newbie
  • *
  • Posts: 78
  • Karma: +0/-0
  • Just joined!
    • Kent
    • View Profile
Re: RX7 turbo 2 issues
« Reply #1 on: September 04, 2017, 07:35:53 PM »
When you say it dies does it cut out completely inc electrics does it bog down or does it splutter and cough

If you half 3 quarter throttle will it rev through to rev limit

Offline clive

  • MRC Founder/President
  • Administrator
  • Major Contributor
  • *****
  • Location: Kent
  • Posts: 9,721
  • Karma: +27/-0
    • View Profile
    • http://mazdarotaryparts.com
Re: RX7 turbo 2 issues
« Reply #2 on: September 04, 2017, 08:13:58 PM »
I had this on one of the TII's we owned and it was the potentiometer  on the throttle body,

It had dead spots as you pressed the throttle pedal
All the best Clive

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #3 on: September 05, 2017, 07:30:42 PM »
It will if there is no load and not driving FCboss.

Okay, how did you get round this? Do you mean tps sensor? If so surely that would mean it wouldn't work when it was just sat there and it would do it with no load :/

Any more help would be awesome

Offline clive

  • MRC Founder/President
  • Administrator
  • Major Contributor
  • *****
  • Location: Kent
  • Posts: 9,721
  • Karma: +27/-0
    • View Profile
    • http://mazdarotaryparts.com
Re: RX7 turbo 2 issues
« Reply #4 on: September 05, 2017, 08:48:01 PM »
Yes the tps sensor, your right in what you say but I seem to remember it was under load, for instance, you would go to pull away at a junction and randomly it would cut out.

Should be able to check it out with a multi meter
All the best Clive

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #5 on: September 05, 2017, 08:53:54 PM »
Yh, I've checked and couldn't see any issues with it. Will check again though, cheers :) any other ideas more than welcome!

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #6 on: September 05, 2017, 09:21:53 PM »
Don't suppose any one has a second hand tps that they know is working?

Offline neil_jdmr

  • MRC Full Club Member
  • Major Contributor
  • *****
  • Posts: 1,340
  • Karma: +10/-0
    • Northumberland
    • View Profile
    • http://i9.photobucket.com/albums/a66/neil_jdmr/IMGP0420.jpg
Re: RX7 turbo 2 issues
« Reply #7 on: September 06, 2017, 09:13:11 AM »
Have you tried another ecu
Standard sequential, standard engine, Oem body, 1.2bar, WI

Twins retired. KKK K27 1.25bar courtesy of Jason and Stu

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #8 on: September 06, 2017, 04:14:43 PM »
Trying to locate my split one but pretty sure I sold them both!!

Offline boosted

  • MRC Full Club Member
  • Major Contributor
  • *****
  • Location: Westbury Wiltshire
  • Posts: 7,440
  • Karma: +21/-0
  • Worryless, Dream more.
    • south west
    • View Profile
Re: RX7 turbo 2 issues
« Reply #9 on: September 06, 2017, 06:52:40 PM »
ok i know nothing about the T11, but think youve got to systematically start changing electrical components due to the loom fault.....but i was thinking is this possibly going into limp mode? which could possibly narrow done the list of components it could be? ie. OMP, boost sensor, knock sensor etc. there are links to manuals on here which sholud help....
92 FD rx7 Twins 13.5psi. Track car
94 Westfield Se 231 rx8 street port powered. Race car
EAT SLEEP ROTOR REPEAT.

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #10 on: September 06, 2017, 08:34:12 PM »
Do things I've changed -

Omp
Map
Maf
Ht leads (magnecor)
Coils (checked resistance all okay)
Fitted grounding kit
All vacuum hoses
A electronic valve in air control part of manifold.

All looms have been replaced.

Picking up an ecu to try next, but will have to fit my spare fuel cut defender to allow for the fact I have an after markets turbo back system and external waste gate so will be boosting more than normal.

Any more ideas welcome on what I should change!

Offline neil_jdmr

  • MRC Full Club Member
  • Major Contributor
  • *****
  • Posts: 1,340
  • Karma: +10/-0
    • Northumberland
    • View Profile
    • http://i9.photobucket.com/albums/a66/neil_jdmr/IMGP0420.jpg
Re: RX7 turbo 2 issues
« Reply #11 on: September 06, 2017, 11:06:35 PM »
I think a different ecu might resolve it but while your down there check the earth connections for the ecu also, if possible continuity test the ecu ground to chassis.
Standard sequential, standard engine, Oem body, 1.2bar, WI

Twins retired. KKK K27 1.25bar courtesy of Jason and Stu

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #12 on: September 07, 2017, 08:40:52 PM »
Borrowed a spare ecu, will be trying to figure this out a bit more tomorrow and over the weekend!

Offline spizwalt

  • MRC Full Club Member
  • Newbie
  • *****
  • Posts: 61
  • Karma: +0/-0
    • glastonbury
    • View Profile
Re: RX7 turbo 2 issues
« Reply #13 on: September 09, 2017, 10:04:09 AM »
So I swapped all the solenoids just to be sure. Then I fitted the, Borrowed ecu and it all works perfectly!!

Thanks for the help, really appreciate it all :) still confused as I swapped the ecu over a while back for a spair one I had sitting around and it still had the same problem, maybe there was another issue as this wa before I changed the engine loom. But all works and I can think about mot and driving it again soon! Just a shame it's coming to end of show season so be time to put away for winter 😂😂

Offline neil_jdmr

  • MRC Full Club Member
  • Major Contributor
  • *****
  • Posts: 1,340
  • Karma: +10/-0
    • Northumberland
    • View Profile
    • http://i9.photobucket.com/albums/a66/neil_jdmr/IMGP0420.jpg
Re: RX7 turbo 2 issues
« Reply #14 on: September 09, 2017, 10:39:58 AM »
Great news!!
Standard sequential, standard engine, Oem body, 1.2bar, WI

Twins retired. KKK K27 1.25bar courtesy of Jason and Stu